BUG: Wind Direction wrong for aggregated buckets

Discussion about generation of graphs and tables
Post Reply
ironedge
Posts: 56
Joined: Tue Sep 23, 2014 9:32 am
Contact:

BUG: Wind Direction wrong for aggregated buckets

Post by ironedge » Thu May 05, 2016 9:31 pm

Hi Boris,

I'd like to report a bug in the aggregation algorithm for the wind direction. I realized it because in my self-made tables, the main wind direction for each month is always "North", which cannot be. I then investigated with the Wind Radar % graph and realized that depending on the resolution, the wind direction always converges towards north, even if it showed a different value when using very granular aggregation.

Means: When drawing the Wind Direction Radar % graph for a given month, using "min10" as resolution, you get a certain wind direction as the main direction in the graph. When using "day1" as resolution, you always end up with "North". It does not make sense that the main wind direction for a month significantly changes when using a different resolution.

Find attached my real-world example from my weather station for February 2016. I took 3 screenshots of the Wind Direction Radar % graph for different resolution values "min10", "hour1" and "day1". The drift towards "North" is obvious, and this happens for any month / aggregation. A correction of this aggregation behavior would be much appreciated. Thank you!
Feb2016_min10.jpg
Feb2016_min10.jpg (32.73 KiB) Viewed 20190 times
Feb2016_hour1.jpg
Feb2016_hour1.jpg (26.66 KiB) Viewed 20190 times
Feb2016_day1.jpg
Feb2016_day1.jpg (27.7 KiB) Viewed 20190 times

ironedge
Posts: 56
Joined: Tue Sep 23, 2014 9:32 am
Contact:

Re: BUG: Wind Direction wrong for aggregated buckets

Post by ironedge » Wed May 25, 2016 2:35 pm

@Boris: Any feedback? Any plans to correct it?
I'm happy to provide any further information if needed.

User avatar
admin
Site Admin
Posts: 332
Joined: Sun Feb 07, 2010 9:22 pm

Re: BUG: Wind Direction wrong for aggregated buckets

Post by admin » Tue Jul 12, 2016 9:55 pm

Hard to get a grip on this. I will have a look at the code again.

ironedge
Posts: 56
Joined: Tue Sep 23, 2014 9:32 am
Contact:

Re: BUG: Wind Direction wrong for aggregated buckets

Post by ironedge » Thu Jul 14, 2016 8:19 pm

Many thanks in advance for your investigations, Boris.

ironedge
Posts: 56
Joined: Tue Sep 23, 2014 9:32 am
Contact:

Re: BUG: Wind Direction wrong for aggregated buckets

Post by ironedge » Sun Oct 09, 2016 8:19 am

Hi @Boris,

Are there any news regarding this bug? Would be really great to get the corrected wind aggregation results.
Thanks!

hymrog
Posts: 9
Joined: Tue Feb 11, 2014 11:24 pm

Re: BUG: Wind Direction wrong for aggregated buckets

Post by hymrog » Sun Nov 13, 2016 6:57 pm

Hello -

It would be much appreciated to have this issue with Wind Direction be resolved. Dont want to be a jerk, but we are paying a fee for this service and it appears this issue has been ongoing for several months.

Thank you
Greg

Post Reply